EIGRP Configuration With Cisco Packet Tracer


EIGRP (Enhanced Interior Gateway Routing Protocol), is a Cisco Proprietary Hybrid Routing Protool. The configuration of EIGRP is similar to other Routing Protocols. In this example, we will configure EIGRP on Packet Tracer.

For our EIGRP example, we will use the below EIGRP topology on Packet Tracer.





Configure IP addresses of routers’ and PCs’ on Packet Tracer
PC0: 192.168.1.1  255.255.255.0  GW:192.168.1.2
PC1: 192.168.2.1  255.255.255.0  GW:192.168.2.2
PC2: 192.168.3.1  255.255.255.0  GW:192.168.3.2
PC3: 192.168.4.1  255.255.255.0  GW:192.168.4.2
ROUTER CONFIGURATION 

192.168.1.2 <ROUTER 0>

Router0> enable
Router0# config terminal
Router0(config)# interface FastEthernet0/0
Router0(config-if)# ip address 192.168.1.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/0
Router0(config-if)# ip address 10.0.0.1 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/1
Router0(config-if)# ip address 20.0.0.1 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# end


192.168.2.2 <ROUTER 1>

Router0> enable
Router0# config terminal
Router0(config)# interface FastEthernet0/0
Router0(config-if)# ip address 192.168.2.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/0
Router0(config-if)# ip address 10.0.0.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/1
Router0(config-if)# ip address 30.0.0.1 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# end

192.168.3.2 <ROUTER 2>

Router0> enable
Router0# config terminal
Router0(config)# interface FastEthernet0/0
Router0(config-if)# ip address 192.168.3.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/0
Router0(config-if)# ip address 40.0.0.1 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/1
Router0(config-if)# ip address 20.0.0.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# end

192.168.1.2 <ROUTER 3>


Router0> enable
Router0# config terminal
Router0(config)# interface FastEthernet0/0
Router0(config-if)# ip address 192.168.4.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/0
Router0(config-if)# ip address 40.0.0.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# exit
Router0(config)# interface serial 0/0/1
Router0(config-if)# ip address 30.0.0.2 255.255.255.0
Router0(config-if)# no shutdown
Router0(config-if)# end

EIGRP CONFIGURATION

192.168.1.2 <ROUTER 0>
Router0(config)# router eigrp 1
Router0(config-router)# network 192.168.1.0
Router0(config-router)# network 10.0.0.0
Router0(config-router)# network 20.0.0.0
Router0(config-router)# no auto
Router0(config-router)# no auto-summary
Router0(config-router)# end

192.168.2.2 <ROUTER 1>

Router0(config)# router eigrp 1
Router0(config-router)# network 192.168.2.0
Router0(config-router)# network 10.0.0.0
Router0(config-router)# network 30.0.0.0
Router0(config-router)# no auto-summary
Router0(config-router)# no auto
Router0(config-router)# end

192.168.3.2 <ROUTER 2>

Router0(config)# router eigrp 1
Router0(config-router)# network 192.168.3.0
Router0(config-router)# network 40.0.0.0
Router0(config-router)# network 20.0.0.0
Router0(config-router)# no auto-summary
Router0(config-router)# no auto

Router0(config-router)# end

192.168.1.2 <ROUTER 3>

Router0(config)# router eigrp 1
Router0(config-router)# network 192.168.4.0
Router0(config-router)# network 40.0.0.0
Router0(config-router)# network 30.0.0.0
Router0(config-router)# no auto-summary
Router0(config-router)# no auto
Router0(config-router)# end

EIGRP Configuration Verification

When we use “show ip eigrp ?” command, we can see our eigrp options that we can use on Packet Tracer.
  Router# show ip eigrp ?
  interfaces  IP-EIGRP interfaces
  neighbors   IP-EIGRP neighbors
  topology    IP-EIGRP Topology Table
  traffic     IP-EIGRP Traffic Statistics
We will see EIGRP neighbors with “show ip eigrp neighbors” command.

Router0# show ip eigrp neighbors 
IP-EIGRP neighbors for process 100
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.0.0.2        Fa4/0          14   00:14:53  40     1000  0   12
1   20.0.0.2        Fa5/0          12   00:14:53  40     1000  0   11
We can verify the EIGRP interfaces with “show ip eigrp interfaces” command.

Router0# show ip eigrp interfaces 
IP-EIGRP interfaces for process 100

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa4/0              1        0/0      1236       0/10           0           0
Fa5/0              1        0/0      1236       0/10           0           0
Fa0/0              0        0/0      1236       0/10           0           0
We can see the whole Topology Table of Router0 and Router1.

outer0# show ip eigrp topology 
IP-EIGRP Topology Table for AS 100/ID(192.168.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 10.0.0.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet4/0
P 20.0.0.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet5/0
P 30.0.0.0/24, 1 successors, FD is 30720
         via 10.0.0.2 (30720/28160), FastEthernet4/0
P 40.0.0.0/8, 1 successors, FD is 30720
         via 20.0.0.2 (30720/28160), FastEthernet5/0
P 192.168.1.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0
P 192.168.2.0/24, 1 successors, FD is 30720
         via 10.0.0.2 (30720/28160), FastEthernet4/0
P 192.168.3.0/24, 1 successors, FD is 30720
         via 20.0.0.2 (30720/28160), FastEthernet5/0
P 192.168.4.0/24, 1 successors, FD is 33280
         via 10.0.0.2 (33280/30720), FastEthernet4/0
We can also see the EIGRP traffic statistics with “show ip eigrp traffic” command.

Router0# show ip eigrp traffic 
IP-EIGRP Traffic Statistics for process 100
  Hellos sent/received: 965/644
  Updates sent/received: 16/12
  Queries sent/received: 0/0
  Replies sent/received:  0/0
  Acks sent/received:  5/7
  Input queue high water mark 1, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
We can check the routing table of Router0. We can see all routing table or we can see onle EIGRP routes.

Router0# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet4/0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.0.0.0 is directly connected, FastEthernet5/0
     30.0.0.0/24 is subnetted, 1 subnets
D       30.0.0.0 [90/30720] via 10.0.0.2, 00:31:24, FastEthernet4/0
D    40.0.0.0/8 [90/30720] via 20.0.0.2, 00:31:24, FastEthernet5/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
D    192.168.2.0/24 [90/30720] via 10.0.0.2, 00:31:24, FastEthernet4/0
D    192.168.3.0/24 [90/30720] via 20.0.0.2, 00:31:24, FastEthernet5/0
D    192.168.4.0/24 [90/33280] via 10.0.0.2, 00:31:24, FastEthernet4/0
Router0# show ip route eigrp 
     30.0.0.0/24 is subnetted, 1 subnets
D       30.0.0.0 [90/30720] via 10.0.0.2, 00:31:20, FastEthernet4/0
D    40.0.0.0/8 [90/30720] via 20.0.0.2, 00:31:19, FastEthernet5/0
D    192.168.2.0/24 [90/30720] via 10.0.0.2, 00:31:20, FastEthernet4/0
D    192.168.3.0/24 [90/30720] via 20.0.0.2, 00:31:19, FastEthernet5/0
D    192.168.4.0/24 [90/33280] via 10.0.0.2, 00:31:19, FastEthernet4/0




Post a Comment

Previous Post Next Post